Knowledgebase: Daddy Carl > General Questions
What do I need to be able to watch the site correctly?
Posted by Scott Williams on 20 January 2015 04:27 PM

A: To play the movies you need to have a PC, Mac or Linux computer with the latest flash player version installed and the latest Javaversion. You can download the latest Flash player version here and java here. 

You can also watch our site on any smartphone using Android, apple iOs or Mobile Windows 8.

We also recommend you to browse our site using the latest Google Chrome, Mozilla Firefox or Safari browsers. Cookies should be enabled.


Comments (0)
Help Desk Software by Kayako goldaccess.helpserve.com